НПО Тепловизор. Теплосчетчики и расходомеры К вершинам эволюции теплосчетчика
     
Расширенный
Регистрация | Пароль?  
О компании Продукция Форум Вакансии
Пользователь    Пароль  
Главное меню
НовостиПродукцияФайлы/ДокументыСтатьиФорумОпросыФотогалереяО компанииРекламодателям
Потребители о нас
"Организация ЗАО «Сервисная Компания «Тепловизор» зарекомендовала себя надежным и профессиональным партнером, выполняющим все поставленные перед ним задачи."

В.В. Холостова, Главный инженер ГУП «ДЕЗ «Выхино»
Наши партнёры
Свернуть/Развернуть ТЕПЛОСЧЕТЧИКИ • ВОДОСЧЕТЧИКИ • РАСХОДОМЕРЫ • ВИС.Т Свернуть/Развернуть
/  Архив форума
   /  Программное обеспечение
/  ошибка подключения к шлюзу

Форум : Программное обеспечение

Название : ошибка подключения к шлюзу

© NegaSoft co., 2005
http://www.teplovizor.ru

URL этой темы
http://www.teplovizor.ru/forum/viewtopic.php?topic_id=290&forum=2


 shaitantehnik :

14.5.13 13:54
 Добрый день, столкнулся со следующей проблемой: Дано: шлюз на вынь 2008 r2, 18 приборов на мт9, и несколько компов с архивистом. Все хорошо работало но в один прекрасный момент началась какая то хрень. То приборы считываются то нет (дает ошибку что устройство не подключено к шлюзу, по факту подключено и отвечает на запросы от конфигуратора). Вопрос: как с этим бороться. Роутеры и прочее оборудование все пакеты исправно пропускает. Причем может считаться прибор а через минуту уже ошибка

 CH :

14.5.13 14:23
 А как диагностировано, что "по факту подключено"? При разрыве соединения с прибором догадаться об этом разрыве можно только при попытке передачи данных, здесь возможны всякие интересные ситуации в зависимости от временных настроек подключения.
Не попали ли вы часом в ситуацию, когда опсос, как это модно, в очередной раз уменьшил таймаут неактивного подключения, отчего механизм keep alive перестал выполнять свою функцию?
Попробуйте использовать возможности ведения лога в модемах, посмотрите, что там за обрывы связи.

 shaitantehnik :

14.5.13 14:47
 Цитата:

CH пишет:
А как диагностировано, что "по факту подключено"? При разрыве соединения с прибором догадаться об этом разрыве можно только при попытке передачи данных, здесь возможны всякие интересные ситуации в зависимости от временных настроек подключения.
Не попали ли вы часом в ситуацию, когда опсос, как это модно, в очередной раз уменьшил таймаут неактивного подключения, отчего механизм keep alive перестал выполнять свою функцию?
Попробуйте использовать возможности ведения лога в модемах, посмотрите, что там за обрывы связи


Подключен по удаленке к шлюзу и вижу что прибор в онлайне, опрашиваю прибор - оветил, тайаут 10 мин, опрос прибор не отвечает.Даже нет значка опроса на шлюзе

 CH :

14.5.13 15:27
 Не совсем понимаю описание "вижу что прибор в онлайне, опрашиваю прибор - оветил, тайаут 10 мин, опрос прибор не отвечает".
Т.е. прибор успешно опрашивается, потом выдерживается таймаут 10 минут, после чего следующий опрос оканчивается неудачей?

 shaitantehnik :

14.5.13 15:43
 К примеру сейчас: 18 всего, 11 подключены к шлюзу (зеленые) с них можно кофигурацию прочитать или перенастроить, опросил, 7 опросились, 4 вылезли с ошибкой - устройство не поключено. вот как так получается?

 shaitantehnik :

14.5.13 16:18
 Цитата:

shaitantehnik пишет:
К примеру сейчас: 18 всего, 11 подключены к шлюзу (зеленые) с них можно кофигурацию прочитать или перенастроить, опросил, 7 опросились, 4 вылезли с ошибкой - устройство не поключено. вот как так получается?


Еще раз опросил, теперь только просились

 CH :

14.5.13 16:54
 Я уже объяснял, как так получается. Эта проблема и на форуме уже обсуждалась.
Модем подключается к маршрутизатору.
Пока через модем не опрашивается прибор, модему передавть нечего - TCP-соединение простаивает.
Через некоторое время простоя опсос разрывает неактивное TCP-соединение, чтобы освободить ресурсы для более активных пользователей.
Модем о разрыве соединения не знает, не знает об этом и MtRoute, поскольку чтобы диагностировать разрыв, через TCP-соединие необходимо попытаться передать данные.
Передача данных начинается в момент следующего опроса прибора, и в этот самый момент факт разрыва соединения становится явным.
При активной функции keep alive модем узнаёт о разрыве соединения через заданное в настройках время (10 минут?) и заново подключается к маршрутизатору.

Попробуйте настроить величину таймаута неактивности для keep_alive минут 5 и посмотрите, есть ли изменения

 shaitantehnik :

14.5.13 20:39
 не помогло, опять тоже самое. то опрашиваются то нет

 shaitantehnik :

15.5.13 14:54
 На текущий момент такая ситуация: есть прибор с тремя системами, первую опрашивает, отстальные 2 вываливает с ощибкой

 CH :

15.5.13 19:00
 Ну что же, ещё что-то конструктивное на основании имеющихся данных предложить не могу. Попопробуйте проанализировать ситуацию по лог-файлам маршрутизатора и модемов.

 shaitantehnik :

15.5.13 23:15
 откатился на 0.80.0 поднялась. пока работает. Программерам скажите что б проверили новый билд. и почему то шлюз логов не ведет. файлы пустые

 CH :

16.5.13 14:16
 Ничего нового в 0.81 нет, давно уже используется. Пустые логи...
Может быть проблемы совместимости с win8? Работа на этой платформе не предполагалась и не тестировалась.