НПО Тепловизор. Теплосчетчики и расходомеры К вершинам эволюции теплосчетчика
     
Расширенный
Регистрация | Пароль?  
О компании Продукция Форум Вакансии
Пользователь    Пароль  
Главное меню
НовостиПродукцияФайлы/ДокументыСтатьиФорумОпросыФотогалереяО компанииРекламодателям
Потребители о нас
"Являясь разработчиком и производителем проборов учета тепловой энергии ЗАО НПО «Тепловизор» безвозмездно осуществляет технические консультации по подбору приборов учета тепловой энергии с привязкой к конкретному источнику или потребителю.
Организация имеет собственные проливочные установки и всё необходимое оборудование для проведения первичной и очередной поверки приборов учета тепловой энергии."


А.И.Гриневский, И.о. главного инженера Филиала №3 «Северо-Восточный» ОАО «МОЭК»
Наши партнёры
Свернуть/Развернуть ТЕПЛОСЧЕТЧИКИ • ВОДОСЧЕТЧИКИ • РАСХОДОМЕРЫ • ВИС.Т Свернуть/Развернуть
/  Архив форума
   /  Программное обеспечение
/  странное поведение mtroute

Форум : Программное обеспечение

Название : странное поведение mtroute

© NegaSoft co., 2005
http://www.teplovizor.ru

URL этой темы
http://www.teplovizor.ru/forum/viewtopic.php?topic_id=503&forum=2


 mobilandr :

13.9.16 21:35
 Здравствуйте. Столкнулся с такой ситуацией.
Был компьютер на котором успешно работал Архивист 1.16.2 с настоенной системой из 30 модемов mt9 через mtroute 0.81.0.
Возникли проблемы с жестким диском, купили новый, установили на него винду заново.
Восстанавливаю систему. Сперва попробовал перенести базу из старой. Получил неадекватное поведение mtroute. Опрашивать всех не желает. Частично серые поля в Архивисте(ini тоже переносил).
Снёс всё по новой.
Прописываю по одному. Где-то на 7-8 модеме получаю mtroute устройсто не подключено... и т.д. со всеми последующими. Попытка запустить конфигуратор с этого же компа - нет подключения. Запускаю конфигуратор на ноуте(в этой же сети) - вижу работающий роутер и подключенные модемы, которые спокойно на нём опрашиваю.
Спустя некоторое время(10-15мин) вдруг подключается один или два прибора "в опрос" на первом компе и я могу войти в конфигуратор, но через некоторое время опять нет. Опрос этих подключившихся идет до конца.
На данный момент ситуация такая, что после первого же запуска Архивист окно Конфигуратора не открывает подключения и Ахивист их не видит(кроме одного-двух подключившихся в первый момент). И так до перезагрузки системы. Со стороннего компа подключения к конфигуратору возможны.
Диск форматил, винду катал уже три раза - результат один. В первый раз столкнулся с таким поведением.
На том же компе в той же сети если запустить "старую" винду на битом диске, скрипя и чихая опрос всех 30 идет разом! как и было. :-?

[ Редактировано mobilandr в 13.9.16 21:10 ]

[ Редактировано mobilandr в 14.9.16 09:44 ]

 CH :

14.9.16 10:59
 Добрый день.
Проблема может заключаться в переносе MtRoute на новый диск копированием. Вообще это допустимо, но пароли (конфигуратора, прокси, ftp-сервера) в конфигурационных файлах маршрутизатора шифрованы с привязкой к старому жёсткому диску, то есть после запуска на новом месте все оказываются неверными. Можно прикинуть последствия.

 mobilandr :

14.9.16 11:13
 Не копированием, а новой установкой всего на новый жесткий диск. Винды, MSDE2000, mtRoute, Archivist.

[ Редактировано mobilandr в 14.9.16 10:16 ]

 CH :

14.9.16 12:28
 По симптомам возможно срабатывает блокировщик по IP-адресу в MtRoute. Скажем, маршрутизатору не нравится поведение Архивиста на локальной машине, из за которого блокируется собственный ip-адрес (для начала на 5 минут, далее прогрессивно увеличивая время блокировки), после чего не принимаются подключения, в том числе, от локального маршрутизатора... а от удалённого, соответственно, принимаются.

Лог-файл маршрутизатора полезно посмотреть.

 mobilandr :

14.9.16 16:38
 Тут запущен конфигуратор, потом Архивист, потом пошел опрос одного прибора, закрыто окно конфигуратора и более оно не открывается.

[ Редактировано mobilandr в 14.9.16 15:41 ]

[ Редактировано mobilandr в 15.9.16 13:05 ]

 CH :

14.9.16 22:28
 Сообщения блокировщика IP это 3 уровень лога, чтобы записывались - нужно увеличить уровень в настройках.

Апдейт: Вообще пришла мне в голову мысль, что собственный адрес (localhost) следует насовсем исключить из блокируемых. Мало ли какие случайные действия могут совершаться в пределах этого ж компьютера в процессе наладки. Рекомендую попробовать изменённый MtrService 0.81.2 - лежит в "разных файлах".

[ Редактировано CH в 15.9.16 11:16 ]