НПО Тепловизор. Теплосчетчики и расходомеры К вершинам эволюции теплосчетчика
     
Расширенный
Регистрация | Пароль?  
О компании Продукция Форум Вакансии
Пользователь    Пароль  
Главное меню
НовостиПродукцияФайлы/ДокументыСтатьиФорумОпросыФотогалереяО компанииРекламодателям
Потребители о нас
"Введенная, при Вашем непосредственном участии как генподрядчика, в эксплуатацию автоматизированная система коммерческого учета тепловой энергии и сетевой воды (АСКУТ-СВ) на ТЭЦ-26 (состоящая из 39 узлов учета, выполненных на базе теплосчетчиков ВИС.Т производства ЗАО «Тепловизор Пром», установленных на магистральных направлениях диаметром от 1200 - 1500мм, подпиточных, химводоподготовки и собственных нуждах ТЭЦ диаметрами от 50 - 600мм)позволяет в режиме реального времени осуществлять коммерческий учет отпущенной тепловой энергии как по отдельным магистральным направлениям так и по станции в целом. Принимать оперативные решения по отпуску тепла, сетевой воды потребителям и в итоге обеспечивать достоверный контроль теплоэффективности ТЭЦ-26."

В.Н.Дегтерев, Заместитель директора по капитальному строительству Теплоэлектроцентраль-26 ОАО «Мосэнерго»
Наши партнёры
Свернуть/Развернуть ТЕПЛОСЧЕТЧИКИ • ВОДОСЧЕТЧИКИ • РАСХОДОМЕРЫ • ВИС.Т Свернуть/Развернуть
/  Архив форума
   /  Программное обеспечение
/  ВИС.Т MT9g Нет ответа прибора

Форум : Программное обеспечение

Название : ВИС.Т MT9g Нет ответа прибора

© NegaSoft co., 2005
http://www.teplovizor.ru

URL этой темы
http://www.teplovizor.ru/forum/viewtopic.php?topic_id=460&forum=2


 igorcall :

14.1.16 17:15
 Добрый день,
пытаемся опросить ВИС.Т MT9g через GPRS:
14.01.2016 15:08:40: >>> Начало сеанса удалённого доступа
14.01.2016 15:08:40: test
14.01.2016 15:08:40: Создание канала связи с прибором
14.01.2016 15:08:40: Устройство связи: TCP/IP
14.01.2016 15:08:40: Подключение к 213.хх.хх.хх:1590
14.01.2016 15:08:42: TCP-подключение установлено
14.01.2016 15:08:42: Канал связи успешно создан
14.01.2016 15:08:42: Запрос доступа к прибору (Modbus-ASCII)
14.01.2016 15:08:49: Запрос доступа к прибору (HydraLink)
14.01.2016 15:09:10: Запрос доступа к прибору (Modbus-RTU)
14.01.2016 15:09:32: Нет ответа прибора
14.01.2016 15:09:32: Закрытие канала связи с прибором
14.01.2016 15:09:32: <<< Сеанс связи завершён с ошибкой
Настройки ВИС.Т:
Режим УД : Опция
Скорость УД: 19200N
MODBUS : ASCII
Паспортные данные: ТС-200-2-2-1-Е2Т 152445
Если сначала прочитать конфигурацию модема через TCP/IP MtCfg, то сразу после чтения конфигурации:
15.01.2016 08:29:19: >>> Начало сеанса удалённого доступа
15.01.2016 08:29:19: test
15.01.2016 08:29:19: Создание канала связи с прибором
15.01.2016 08:29:19: Устройство связи: TCP/IP
15.01.2016 08:29:19: Подключение к 213.хх.хх.хх:1590
15.01.2016 08:29:21: TCP-подключение установлено
15.01.2016 08:29:21: Канал связи успешно создан
15.01.2016 08:29:21: Запрос доступа к прибору (HydraLink)
15.01.2016 08:29:43: Запрос доступа к прибору (Modbus-RTU)
15.01.2016 08:30:07: Запрос доступа к прибору (Modbus-ASCII)
15.01.2016 08:30:09: Получен ответ прибора (ModBus-ASCII)
15.01.2016 08:30:09: Запрос CRC спецификаций/настроек прибора
15.01.2016 08:30:11: Спецификации/настройки прибора не изменялись
15.01.2016 08:30:11: Запрос текущего времени часов прибора
15.01.2016 08:30:12: Чтение заголовка архива
15.01.2016 08:30:14: Запрос маски измеряемых параметров
15.01.2016 08:30:15: Чтение значений текущих измеряемых параметров
15.01.2016 08:30:23: Ошибка чтения заголовка архива
15.01.2016 08:30:23: Потеряно IP-соединение
15.01.2016 08:30:23: Закрытие канала связи с прибором
15.01.2016 08:30:23: <<< Сеанс связи завершён с ошибкой

15.01.2016 08:31:07: >>> Начало сеанса удалённого доступа
15.01.2016 08:31:07: test
15.01.2016 08:31:07: Создание канала связи с прибором
15.01.2016 08:31:07: Устройство связи: TCP/IP
15.01.2016 08:31:07: Подключение к 213.хх.хх.хх:1590
15.01.2016 08:31:09: TCP-подключение установлено
15.01.2016 08:31:09: Канал связи успешно создан
15.01.2016 08:31:09: Запрос доступа к прибору (Modbus-ASCII)
15.01.2016 08:31:14: Запрос доступа к прибору (HydraLink)
15.01.2016 08:31:34: Запрос доступа к прибору (Modbus-RTU)
15.01.2016 08:31:56: Нет ответа прибора
15.01.2016 08:31:56: Закрытие канала связи с прибором
15.01.2016 08:31:56: <<< Сеанс связи завершён с ошибкой


В чем может быть причина?

[ Редактировано igorcall в 14.1.16 17:27 ]

[ Редактировано igorcall в 15.1.16 09:37 ]

 CH :

18.1.16 12:08
 Здравствуйте.
Для начала, я не рекомендую использовать ASCII-режим протокола MODBUS. Крайне предпочтительна настройка в приборе RTU+.
При этом для использования прозрачного TCP/IP-режима подключения, в настройках драйвера в Архивисте, привязанных к прибору, необходимо активировать опцию использования TCP-адаптера стороннего производителя (в противном случае Архивист будет предполагать, что подключается к встроенному TCP-адаптеру ВИСТа и использует поддерживаемый им режим MODUS-TCP вместо прозрачного). Как это сделать см. в readme-файле драйвера ВИСТ.

 igorcall :

18.1.16 13:28
 Добрый день.
Ваши рекомендации выполнены.
Ситуация не изменилась.
Что-то с настройками TCP/IP сессии?

 CH :

18.1.16 14:12
 Не изменилось - это "Нет ответа прибора"?
Для упрощения ситуации, чтобы Архивист не перебирал при каждом подключении связные протоколы, можно в тех же настройках драйвера отставить только MODBUS-RTU (как - описано там же в readme). Несколько раз попробовать провести опрос.
При этом, считая, что в целом настройки верные - проходило же у вас однажды подключение с частичной передачей данных - проблема может оказаться просто в качестве связи. По настройкам TCP возможно увеличение интервала ожидания ответа на команды в общих настройках драйвера, но это средство борьбы с той же некачественной связью, стоит ли увеличивать значение таймаута по умолчанию - на собственное усмотрение.

 igorcall :

18.1.16 16:03
 MtCfg показывает - сигнал 100%.
Основное следующее:
TCP-подключение установлено
Канал связи успешно создан
Запрос доступа к прибору (Modbus-RTU)
Нет ответа прибора
Закрытие канала связи с прибором
Сеанс связи завершён с ошибкой
Т.е. соединение создается, но нет ответа от прибора.
Что можно настроить в модеме?

 CH :

19.1.16 11:40
 В приборе: опция, 19200N, MODBUS-RTU+. Проверить совпадение сетевого номера MODBUS в приборе и в настройках подключения в Архивисте (по умолчанию 1).
В модеме ничего особенного настраивать не нужно, раз уж сетевое подключение устанавливается.
Не подключено ли к прибору что-то параллельно (например принтер)?

 igorcall :

19.1.16 12:09
 Да, в приборе выставлено : опция, 19200N, MODBUS-RTU+, сетевой номера MODBUS = 1.
Физически принтер не подключен.

 CH :

20.1.16 11:41
 Конструктивные предложения у меня закончились. Остаётся предположить какие-то проблемы с сетевой передачей данных или аппаратную неисправность в приборе.

 mobilandr :

20.1.16 18:27
 На 9600 пробовали?

[ Редактировано mobilandr в 20.1.16 17:28 ]

[ Редактировано mobilandr в 20.1.16 17:30 ]

 igorcall :

25.1.16 08:39
 Прибор можно настроить на 9600, а как настроить модем на 9600?

 CH :

28.1.16 12:51
 точно так же, как вы меняете любые другие настройки модема. Команды AT+IPR=... стандартные, или, если не хочется вводить команды руками в терминале, можно использовать соответствующий пункт в меню MtCfg.
Впрочем, я не думаю, что это поможет.